Password Reset Emails
Incident Report for Loggly
Resolved
This incident has been resolved.
Posted 30 days ago. Nov 19, 2018 - 13:55 PST
Monitoring
Due to high volume, delivery of password reset emails is taking longer than usual.
Posted 30 days ago. Nov 19, 2018 - 10:14 PST
This incident affected: Website Availability.